rsdb.net
当前位置:首页 >> org.ApAChE.poi.xssF >>

org.ApAChE.poi.xssF

http://poi.apache.org/download.html 下载poi-bin-3.9-20121203.zip 解压后 poi-ooxml-3.9-20121203.jar 这个jar文件中有 org.apache.poi.xssf包

有啊,不知道你是不是Apache网站上下载的POI,最新稳定版是3.8 XSSF这个package在解压后的poi-ooxml-3.8-20120326.jar这个文件里。

XSSFWorkbook:poi-ooxml-3.9-20121203.jar.org.apache.poi.xssf.usermodel.XSSFWorkbook HSSFWorkbook:poi-3.9-20121203.jar.org.apache.poi.hssf.usermodel.HSSFWorkbook

org.apache.poi.xssf 包 在 poi-ooxml jar 里面 你可以在maven pom.xml 这样配置 org.apache.poipoi3.14org.apache.poipoi-ooxml3.14org.apache.poipoi-ooxml-schemas3.14

首先:确定jar包是否已经导入 需导入jxl.jar,poi-3.11-20141221.jar,commons-io-2.2.jar除外的jar包 其次看jdk版本是否大于1.6.0_18,若没有,则会在new XSSFWorkbook()时报错

确定导入jar包了吗?你找找看是不是jar缺失或者jar的版本不行,你试试!希望能帮到你!

下载最新poi http://www.apache.org/dyn/closer.cgi/poi/release/bin/poi-bin-3.8-20120326.zip 加入包 poi-3.8\ 所有jar包 poi-3.8\ooxml-lib下的:三个jar包

包中一共有8个jar需要导入到eclipse。除了根目录下的五个,还有ooxml-lib下的三个。

缺少jar包:xmlbeans-版本年月.jar

我也遇到了同样的问题. 如果操作xls文件的时候没有问题, 当操作xlsx文件的时候就会报这个错. 我的问题已经解决了. 原因: 主要是因为xls和xlsx的解析方式不一样, 导致使用的类不同. xls返回的是HSSFWorkbook , 而xlsx返回的是XSSFWorkbook. 我自...

网站首页 | 网站地图
All rights reserved Powered by www.rsdb.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com